Atatürk

Sisteminizde X bozuk paket bulunuyor! “Bozuk” süzgecini kullanarak bunu görebilirsiniz.

Kategori GNU/Linux
22.11.2011
6.133 kez okundu
linux mint

Başlıkta okuduğunuz hata mesajı ile Güncelleme Yöneticisi‘ni açtığımda karşılaştım. Bu hatayı almamın nedeni adı üzerinde sistemde bozuk paket olması ve buna neden olan da bilgisayarıma en son kurduğum Wine programıydı.

Siz de bu hatayı alıyorsanız muhtemelen bilgisayarınıza kurduğunuz yazılımlardan biri tam olarak kurulamamıştır veya kurulurken bir hata oluşmuştur. Sorunun çözümü de oldukça basit.

bozuk-paket-suzgeci

Uçbirim‘i açıp aşağıdaki kodu yazın.

sudo apt-get install -f

Not: Synaptic Paket Yöneticisi ve Güncelleme Yöneticisi’nin kapalı olduğundan emin olun. Açık olursa muhtemelen hata mesajı alacaksınız.

ucbirim-bozuk-suzgeci-sorunu

Kodu yazdıktan sonra yukarıdaki gibi size, sisteminizden hangi dosyaların kaldırılacağı ve hangilerinin kurulacağıyla ilgili bir ekran çıkacak. Burada “Y” tuşuna basın. İşlemin bitmesini bekleyin. Hepsi bu kadar.

Share Button

Comments of this post

Cez Can

Cez Can
20 Aralık 2011

Güzel ve faydalı, ben de bir kontrol ediyim dedim problem yok
cez@cez-Satellite-M70 ~ $ sudo apt-get install -f
[sudo] password for cez:
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 20 not upgraded.
cez@cez-Satellite-M70 ~ $
bu sonuç itibari ile ne yapmam gerekiyor acaba ??
Önceden Teşekkürler
Kolay gelsin

[Cevapla]

Ünal

Ünal
23 Eylül 2020

Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
ike libjpeg62:i386 mint-backgrounds-sonya qml-module-qtquick-controls
qml-module-qtquick-dialogs qml-module-qtquick-layouts
qml-module-qtquick-privatewidgets qml-module-qtquick-window2
qml-module-qtquick2 qtdeclarative5-controls-plugin
qtdeclarative5-dialogs-plugin qtdeclarative5-qtquick2-plugin
qtdeclarative5-quicklayouts-plugin qtdeclarative5-window-plugin
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 39 paket yükseltilmeyecek.

sonucu alındığında

sudo apt autoremove
Paket listeleri okunuyor… Bitti
Bağımlılık ağacı oluşturuluyor
Durum bilgisi okunuyor… Bitti
Aşağıdaki paketler KALDIRILACAK:
ike libjpeg62:i386 mint-backgrounds-sonya qml-module-qtquick-controls
qml-module-qtquick-dialogs qml-module-qtquick-layouts
qml-module-qtquick-privatewidgets qml-module-qtquick-window2
qml-module-qtquick2 qtdeclarative5-controls-plugin
qtdeclarative5-dialogs-plugin qtdeclarative5-qtquick2-plugin
qtdeclarative5-quicklayouts-plugin qtdeclarative5-window-plugin
0 paket yükseltilecek, 0 yeni paket kurulacak, 14 paket kaldırılacak ve 39 paket yükseltilmeyecek.
Bu işlem tamamlandıktan sonra 37,0 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor … 341649 dosya veya dizin kurulu durumda.)
Kaldırılıyor: ike (2.2.1+dfsg-4) …
Kaldırılıyor: libjpeg62:i386 (1:6b2-2) …
Kaldırılıyor: mint-backgrounds-sonya (1.1) …
Kaldırılıyor: qtdeclarative5-controls-plugin (5.5.1-1ubuntu1) …
Kaldırılıyor: qml-module-qtquick-controls:amd64 (5.5.1-1ubuntu1) …
Kaldırılıyor: qtdeclarative5-dialogs-plugin:amd64 (5.5.1-1ubuntu1) …
Kaldırılıyor: qml-module-qtquick-dialogs:amd64 (5.5.1-1ubuntu1) …
Kaldırılıyor: qtdeclarative5-quicklayouts-plugin (5.5.1-1ubuntu1) …
Kaldırılıyor: qml-module-qtquick-layouts:amd64 (5.5.1-1ubuntu1) …
Kaldırılıyor: qml-module-qtquick-privatewidgets:amd64 (5.5.1-1ubuntu1) …
Kaldırılıyor: qtdeclarative5-window-plugin:amd64 (5.5.1-2ubuntu6) …
Kaldırılıyor: qml-module-qtquick-window2:amd64 (5.5.1-2ubuntu6) …
Kaldırılıyor: qtdeclarative5-qtquick2-plugin:amd64 (5.5.1-2ubuntu6) …
Kaldırılıyor: qml-module-qtquick2:amd64 (5.5.1-2ubuntu6) …
Tetikleyiciler işleniyor: man-db (2.7.5-1) …
işlemi ile de temizleme yapılabilir.

Kolay gelsin

[Cevapla]